Monitorizar posiciones en Google con Excel

Pese a no ser nada amigo de monitorizar keywords, hay veces que por diversas razones no te queda más remedio. Existe una infinidad de fórmulas en el mercado, herramientas en la nube, con proxis con IPs de todo el mundo, histórico, rankings diarios, etc. Sin embargo, lo cierto es que hay poca documentación para tratar de hacerlo de forma simple y gratis, pero algo más automatizado que ir mirando con crtl + mayusc + n y buscar a pelo 😉

Una opción puede ser Free Monitor for Google de Clever Stats, que sigue funcionando igual de bien que hace años para pocas querys. Sin embargo, quería algo más simple todavía, que tirase en Google Drive o mejor todavía con Excel.

Gracias de nuevo a Estela Franco que me ha ayudado a screapear con Excel SEO Tools las URLs de la serp en busca de un determinado dominio dada una keyword dada, para ello:

Concatenamos http://www.google.es/search?q= + la Query que queremos.

Ahora la maravilla para Excel SEO Tools (no funciona en Drive): =XPathOnUrl(A2;”//h3[@class=’r’]/a”;”href”) (así hasta 10 veces en 10 filas, para sacar el TOP10)

La posición, la sacamos con: =COINCIDIR(“TRUE”;B3:B12;0)

Y la URL con =INDICE(A3:A12;D3)

Deja un comentario